MySQL 8.0 驱动与阿里druid版本兼容问题解决

MySQL 8.0 驱动与阿里druid版本不兼容会导致有报错问题,本文就详细的介绍一下解决方法,具有一定的参考价值,感兴趣的可以了解一下

本文主要介绍了mysql 8.0 驱动与阿里druid版本兼容问题解决,具体如下:

MySQL 8.0 驱动与阿里druid版本兼容问题解决

注意:

这个异常表面druid数据源的版本与mysql 8.0的驱动版本不匹配,解决方法如下:https://repo1.maven.org/maven2/com/alibaba/druid/

确保mysql 8.0的驱动如下

?

1

2

3

4

5

<dependency>

<groupid>mysql</groupid>

<artifactid>mysql-connector-java</artifactid>

<version>8.0.11</version>

</dependency>

确保druid的版本如下

?

1

2

3

4

5

<dependency>

<groupid>com.alibaba</groupid>

<artifactid>druid</artifactid>

<version>1.1.10</version>

</dependency>

附上druid各个版本的驱动jar 包下载方式如下:

重新刷新pom,更新maven,如下图:

MySQL 8.0 驱动与阿里druid版本兼容问题解决

然后启动项目,run:

MySQL 8.0 驱动与阿里druid版本兼容问题解决

见到下面这句红色提醒日志,则表示已经匹配成功:

MySQL 8.0 驱动与阿里druid版本兼容问题解决

接下来就可以操作数据库了,但是如果你连mysql 8.0驱动和数据库连接都没搞定的话,那就看这篇吧。

mysql 8.0及对应驱动包匹配注意点

到此这篇关于mysql 8.0 驱动与阿里druid版本兼容问题解决的文章就介绍到这了,更多相关mysql 8.0驱动与阿里druid兼容内容请搜索钦钦技术栈以前的文章或继续浏览下面的相关文章希望大家以后多多支持钦钦技术栈!

原文链接:https://blog.csdn.net/lizhengyu891231/article/details/99403561

版权声明:本文(即:原文链接:https://www.qin1qin.com/catagory/6649/)内容由互联网用户自发投稿贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌抄袭侵权/违法违规的内容, 请发送邮件至 630367839@qq.com 举报,一经查实,本站将立刻删除。

(0)
上一篇 2022-07-29 10:19:14
下一篇 2022-07-29 10:19:27

软件定制开发公司

相关阅读

发表回复

登录后才能评论
通知:禁止投稿所有关于虚拟货币,币圈类相关文章,发现立即永久封锁账户ID!