关于MyBatis连接MySql8.0版本的配置问题

这篇文章主要介绍了关于MyBatis连接MySql8.0版本的配置问题,本文给大家介绍的非常详细,对大家的学习或工作具有一定的参考借鉴价值,需要的朋友可以参考下

在学习mybatis时,遇到了一个错误,错误如下:

Error querying database. Cause: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure

错误原因:

  • 本地使用的数据库版本为MySQL8.0
  • 在pom.xml配置文件中导入MySQL的jar包版本为

关于MyBatis连接MySql8.0版本的配置问题

因为本地数据库版本与导入MySQL的jar包版本不一致引起的错误

解决办法:

[1] 本地安装相应版本的数据库,因为我本地安装了MySQL5.6和MySQL8.0,将数据库切换为MySQL5.6解决问题
[2]修改pom.xml配置文件,数据库不用切换

?

1

2

3

4

5

<dependency>

<groupId>mysql</groupId>

<artifactId>mysql-connector-java</artifactId>

<version>8.0.18</version>

</dependency>

补充:mybatis 连接mysql8.0异常

The reference to entity "serverTimezone" must end with the ';' delimiter.

对实体“serverTimeZone”的引用必须以“;”分隔符结尾。
解决的方案为
在xml的配置文件中 ;要用 & 代替。

?

1

<property name="jdbcUrl"> jdbc:mysql://localhost:3306/exam?characterEncoding=utf8&amp;serverTimezone=UTC </property>

到此这篇关于关于MyBatis连接MySql8.0版本的配置问题的文章就介绍到这了,更多相关MyBatis连接MySql8.0内容请搜索钦钦技术栈以前的文章或继续浏览下面的相关文章希望大家以后多多支持钦钦技术栈!

原文链接:https://blog.csdn.net/weixin_42537655/article/details/111573616

版权声明:本文(即:原文链接:https://www.qin1qin.com/catagory/9753/)内容由互联网用户自发投稿贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌抄袭侵权/违法违规的内容, 请发送邮件至 630367839@qq.com 举报,一经查实,本站将立刻删除。

(0)
上一篇 2022-08-07 8:55:10
下一篇 2022-08-07 8:55:26

软件定制开发公司

相关阅读

发表回复

登录后才能评论
通知:禁止投稿所有关于虚拟货币,币圈类相关文章,发现立即永久封锁账户ID!